Release Date: October 29, 2025
|
ID |
Release Type |
Release Title |
Release Description |
|---|---|---|---|
|
86031 |
Feature |
Added the ability to query items in FO by attribute |
Using the new ItemsByAttributes procedure, users can query items based on one or more specified attribute values. Querying for invalid attributes will result in an error response. |
|
90625 |
Feature |
Digital Commerce can now automatically create and post prepayment proposals in D365 FO |
The process creates a 100% prepayment proposal for a sales order and posts the corresponding prepayment invoice, returning the invoice number on success or an error message on failure. |
|
91088 |
Feature |
Resolved an issue where changing a key value during an update caused Cloud Connect to create a new record without deleting the old one |
Cloud Connect now properly deletes the previous record before creating the new one when key values change. |
|
89672 |
Improvement |
Removed Experlogix Configurator user role |
To avoid confusion, the Experlogix Configurator user role is no longer available. Instead, administrators should use the form-specific roles to implement more granular permissions. |
|
89348 |
Improvement |
Added new Read parameter to Experlogix Advanced Settings in FO |
The Read parameter, found on the Experlogix parameters form > Advanced settings, allows users to control the behavior used when a read action is executed on the Process Document. |
|
89614 |
Improvement |
Query Designer now supports exact matching on enum fields in D365 FO |
Using the "=" operator on an enum field filters strictly on the provided value without modifying or interpreting symbols, returning only exact matches. |
|
87812 |
Improvement |
Added logging for token request and response |
When getting a token for the Integration API, the success/failure of the request and response is logged in the Experlogix FO Logging form. If the token acquisition fails, additional details are provided in the logs. |
|
91256 |
Improvement |
Updated FO Logger logic to consistently record request and response duration |
The Experlogix FO Logger no longer shows a duration of zero for requests and responses after long logging sessions. |
|
91160 |
Fix |
Fixed a bug causing the FO logger to mistakenly covert datetime values |
Datetime values in the logger are no longer adjusted for time zone. The values are displayed as they appear in the Process Document. |
|
91202 |
Fix |
Fixed a bug causing Product Name, Search Name, and Description to be updated unexpectedly during processing |
Product Name, Search Name, and Description fields on a product retain their expected values after processing a document that interacts with them. |
|
91216 |
Fix |
Resolved an issue where records with fixed key values in compositions did not trigger the correct “already exists” error during save |
The process now automatically retries the operation using an “update” action when a create fails due to an existing record. |
|
88735 |
Fix |
Renamed a user role |
The BOM Route generator role has been renamed to Experlogix BOM Route generator. |
|
91613 |
Fix |
Fixed a bug causing the BOM IDs to not change as expected when reconfiguring |
When using matching in FO and reconfiguring, leading to updates to the BOM contents, a new BOM ID is now created as expected instead of reusing the existing BOM ID. |
|
91740 |
Fix |
Resolved an issue where queries using the "filter" operator with empty strings did not return records in Cloud Connect |
Queries now behave as expected with empty string filters returning matching records when using either "=" or "filter" operators. |