Release Date: July 16, 2024
|
ID |
Type |
Title |
Description |
|---|---|---|---|
|
75959 |
Feature |
A new toggle added to BRG page |
A new toggle control, ‘Allow auto-generate in company,’ was added on the BRG page. The toggle can be turned on or off based on the requirement. |
|
77216 |
Feature |
A new toggle added on the Experlogix Parameters tab |
A new toggle, ‘Process in batch job’, was added to the Advanced tab of the Experlogix Parameters tab. Turning on this toggle will process the incoming configurations using a batch job to support long-running configurations. |
|
77222 |
Feature |
Batch processing for process document |
The Integration API responds to requests when the ‘Process in batch job’ toggle is set to ‘Yes’ in the Experlogix parameters tab and sends a queued response. |
|
77302 |
Feature |
Batch Group parameter added |
A new parameter, Batch Group, is added to the Experlogix parameters page. This parameter is used to execute batch jobs. |
|
77451 |
Feature |
Process state saved in Integration API |
The process state is saved in the Integration API upon successfully processing a request. |
|
77780 |
Feature |
Batch job in Microsoft Dynamics 365 F&O |
It is possible to create a batch job in Microsoft Dynamics 365 F&O. |
|
77787 |
Feature |
New table for batch processing |
A new table is added to the Integration API for batch processing. |
|
77788 |
Feature |
New entry created in a table for batch processing |
A new entry is added to the new table if batch processing is enabled. |
|
77789 |
Feature |
Status of batch job updated on execution |
The status of the batch job is updated to 'Executing' when the batch job starts running. |
|
77790 |
Feature |
Processing record deleted after a batch job is completed |
The processing record created by the batch job is deleted from the new table on successful record processing. |
|
77791 |
Feature |
An error message returned if another batch job is running |
If an existing batch job is in progress and a new process document for the same batch job and entity, an error ‘A configuration is already processing’ is returned as response. |
|
77792 |
Feature |
Confirmation message for opening Configurator |
A confirmation message is displayed when opening the Configurator if a batch job is running for the record. The user can select ‘Yes’ to open the Configurator. |
|
77872 |
Feature |
Saving process state again in Microsoft Dynamics 365 F&O |
It is possible to re-save the process state in Microsoft Dynamics 365 F&O after initially saving it if there were errors in the initial run. |
|
78068 |
Feature |
The process state added in logs |
The actual process state going to the integration API is displayed in the Microsoft Dynamics 365 F&O logs. |
|
78457 |
Feature |
An error message returned for an invalid template record |
An error message is returned if a template record does not exist in the host. |
|
76716 |
Fix |
Label changed for Integrator Client Secret |
On the Experlogix Parameters form, the label ‘Integrator Client Secret’ changed to ‘Integration Client Secret’. |
|
76717 |
Fix |
‘Enabled’ label added to the Log/Trace monitor page |
A label was missing on the Log/Trace monitor page to enable the Logging. After the fix, the ‘Enabled’ label is added. |
|
76976 |
Fix |
It is not possible to set the Resource Type of Resource Requirements using Cloud Connect |
It was not possible to set the Resource Type of Resource Requirements using Cloud Connect. After the fix, it is possible. |
|
78085 |
Fix |
Using the AUTO number series, it is not possible to create multiple configurations with the same item |
Using the AUTO number series, saving multiple configurations with the same item displayed an error. After the fix, it is possible to save multiple configurations with same item using AUTO number series. |
|
78514 |
Fix |
The Verify API displays an error despite having correct values |
The Verify API displayed a 400 error despite having correct values. After the fix, the Verify API returns a success message with the version number. |
|
78521 |
Fix |
Reconfiguring a failed sales order displays an error |
Reconfiguring a failed sales order displayed an error. After the fix, the user can reconfigure the sales order, creating a batch job. |
|
78902 |
Fix |
A ‘Configuration Index’ field added on the Configuration batch process page |
It was not possible to determine whether a Configuration was processing or had an error. With the new ‘Configuration Index’ field on the Configuration batch process page, the customer can easily find the information. |